您现在的位置是:首页 > 正文

ias 配置服务器 文件属性,WX5002与Windows IAS配合实现同一SSID不同VLAN功能(即动态mac-vlan功能)的典型配置...

2024-01-30 22:06:01阅读 0

WX5002与Windows IAS配合实现同一SSID不同VLAN功能(即动态mac-vlan功能)的典型配置

适用WX5002版本:Comware Software, Version 5.20, Release 1106P02

一、组网需求

WX5002、WA2110、H3C POE交换机、便携机(安装有11b/g无线网卡)、Windows IAS服务器

二、组网图

d1eb18e73f24b929b2031a1f7b1c61fa.png

WX5002的IP地址为192.168.1.9。

交换机为三层交换机,WA2110在VLAN 1,WX5002和交换机之间为Trunk,通过VLAN1、2、3。

Windows IAS服务器在VLAN100,地址为192.168.100.10。

交换机上VLAN1、2、3、100的接口地址分别是192.168.1.254、192.168.2.254、192.168.3.254和192.168.100.254。

本例中WA2110的序列号为210235A22W0077000088。

SSID的名称为H3C-mac-vlan。

三、WX交换机的典型配置

#

version 5.20, Release 1106P02

#

sysname H3C

#

domain default enable isp

#

port-security enable

#

dot1x authentication-method eap

#

vlan 1

#

vlan 2 to 3

#

radius scheme radius1

primary authentication 192.168.100.10

primary accounting 192.168.100.10

key authentication h3c

key accounting h3c

user-name-format without-domain

nas-ip 192.168.1.9

#

domain isp

authentication lan-access radius-scheme radius1

authorization lan-access radius-scheme radius1

access-limit disable

state active

idle-cut disable

self-service-url disable

domain system

access-limit disable

state active

idle-cut disable

self-service-url disable

#

dhcp server ip-pool 1

network 192.168.1.0 mask 255.255.255.0

gateway-list 192.168.1.254

expired day 3

#

dhcp server ip-pool 2

network 192.168.2.0 mask 255.255.255.0

gateway-list 192.168.2.254

expired day 3

#

dhcp server ip-pool 3

network 192.168.3.0 mask 255.255.255.0

gateway-list 192.168.3.254

expired day 3

#

wlan rrm

dot11a mandatory-rate 6 12 24

dot11a supported-rate 9 18 36 48 54

dot11b mandatory-rate 1 2

dot11b supported-rate 5.5 11

dot11g mandatory-rate 1 2 5.5 11

dot11g supported-rate 6 9 12 18 24 36 48 54

#

wlan service-template 1 crypto

ssid H3C-mac-vlan

bind WLAN-ESS 1

authentication-method open-system

cipher-suite tkip

security-ie wpa

service-template enable

#

interface NULL0

#

interface Vlan-interface1

ip address 192.168.1.9 255.255.255.0

#

interface Vlan-interface2

ip address 192.168.2.9 255.255.255.0

#

interface Vlan-interface3

ip address 192.168.3.9 255.255.255.0

#

interface GigabitEthernet1/0/1

port link-type trunk

port trunk permit vlan all

#

interface GigabitEthernet1/0/2

port link-type trunk

port trunk permit vlan all

#

interface M-Ethernet1/0/1

#

interface WLAN-ESS1

port link-type hybrid

port hybrid vlan 1 to 3 untagged

mac-vlan enable

port-security port-mode userlogin-secure-ext

port-security tx-key-type 11key

#

wlan ap ap1 model WA2100

serial-id 210235A22W0077000088

radio 1

service-template 1

radio enable

#

ip route-static 0.0.0.0 0.0.0.0 192.168.1.254

#

dhcp enable

#

user-interface aux 0

user-interface vty 0 4

#

return

四、Windows AD ( Active Directory )的相关配置

1、增加两个用户组group2和group3

ea426ce05df87ed0cdb178cf0ff761f1.png

51e17902a09dc9997cfeaeb957a20782.png

f1908faf8b3d4156d4be957b9c905920.png

2、增加两个用户222和333,两个用户分别隶属于用户组group2和group3

9484d8c59f67f4c495eddf06bf73b257.png

527010d87252ed5420e153d1893cb009.png

b6e901bba0f62f66a99d65ad355304d8.png

c2f7712470e7cbc431d62942bb3a38a5.png

五、Windows IAS的相关配置

1、RADIUS客户端的相关配置

l保证IP地址的配置与WX5002中的配置一致(如本例中为192.168.1.9)。

l保证共享密钥中的配置与WX5002中的配置一致(如本例中为h3c)。

配置信息如下图所示:

6b73a795614ae110f1c691eb5b5d331b.png

2、远程访问策略的相关配置

第一步:建立远程访问策略“WX5002-group2”,在策略状况中选择“Windows-Groups匹配‘WLAN\group2’”,在使用的远程访问策略中选择“授予远程访问权限”,然后点击“编辑配置文件”,如下图所示

089f6403385bd9fdffa1c66a821221e1.png

在“编辑配置文件”的对话框中选择“EAP方法”,如下图所示:

51e64d547339962f0be57395d8250369.png

在“EAP方法”中选择“受保护的EAP(PEAP)”,如下图所示:

43ccb786fdbef7192994421704b18c5a.png

并在选中EAP方法后点击“编辑”,此EAP方法应处于可编辑状态,如下图所示:

ab14e19bc4df859ec7e3029bdda7cf2c.png

第二步:在“编辑配置文件”的对话框中选择“高级”,在高级属性中需手动添加3个属性,分别是“Tunnel-Medium-Type”、“Tunnel-Pvt-Group-ID”、“Tunnel-Type”,各属性的内容如下图所示:

注:其中Tunnel-Pvt-Group-ID代表要下发的vlan号,采用“十六进制方式”,0x00000002代表下发的vlan id为2

ed330f8714fb24694cca746ee7f93e81.png

第三步:建立远程访问策略“WX5002-group3”,在策略状况中选择“Windows-Groups匹配‘WLAN\group3’”,同时下发vlan id为3,其他属性与远程访问策略“WX5002-group2”相同,如下图所示:

d2764671e38a0ffe9959bbbc7b9383b8.png

deece2765bb627759aef0cb490f8ef22.png

六、Windows无线客户端的相关配置

1、在Windows无线客户端中,通过“刷新网络列表”搜索相应的SSID,本例中的SSID为“H3C-mac-vlan”,然后选择“更改高级设置”,如下图所示:

e398b3d27f027d576d4997100a82142c.png

2、在弹出的对话框中,选择“无线网络配置”,在“首选网络”中选择“H3C-mac-vlan”,然后点击“属性”,如下图所示:

df7697655c6fcd8f88ce3f12aea293fd.png

3、在弹出的“H3C-mac-vlan属性”对话框中,在“关联”项中根据SSID的配置,在“网络验证(A)”中选择“WPA”,在“数据加密(D)”中选择“TKIP”,如下图所示:

c1367f5de85bf24dc3ebb8c5d01fc881.png

4、选择“验证”项,在“EAP类型(T)”中选择“受保护的EAP (PEAP)”,然后点击“属性”,如下图所示:

eb14ada9b08cb11f7b60584b704c9901.png

5、在弹出的“受保护的EAP属性”的对话框中,如需验证服务器证书,在“验证服务器证书(V)”选项上打勾,否则勾掉该选项。然后点击“配置”,本例中不验证服务器证书,如下图所示:

3814c070dcee30a8e8a74161f35eabc7.png

6、在弹出的“EAP MSCHAPv2属性”对话框中,勾掉“自动使用Windows登录名和密码”选项,然后选择“确定”。

5ed56922efaa090cb7ecfdf5b58dddcb.png

七、验证结果

1、按照以上步骤完成客户端设置后,选择连接SSID H3C-mac-vlan,对弹出的对话框中输入用户名222和密码222,客户端属于VLAN 2,获取192.168.2.0/24网段地址,如下图所示:

57d5ff3e550f12c81053b1d98212331b.png

cb9095fc986c068fb422a9eff7a9d1ea.png

2、选择连接SSID H3C-mac-vlan,对弹出的对话框中输入用户名333和密码333,客户端属于VLAN 3,获取192.168.3.0/24网段地址,如下图所示:

23c5a42f02d356d050bc1cf0b4fe54a7.png

78532e639440016cc0a1edefeacb6f3f.png

网站文章

  • excel表计算机实践操作,Excel电子表格计算机实践任务书

    《Excel电子表格计算机实践任务书》由会员分享,可在线阅读,更多相关《Excel电子表格计算机实践任务书(12页珍藏版)》请在装配图网上搜索。1、1,计算机实践 Excel2003电子表格,2,一、...

    2024-01-30 22:05:30
  • 程序员怎么找工作?程序员找工作越来越难怎么办?

    程序员怎么找工作?程序员找工作越来越难怎么办?

    最近互联网大厂裁员的消息很多,直接原因还是来自于业绩压力。对于互联网公司而言,在外部公司空间增长猥琐的背景下。想要改善业绩,最直接到底方法还是裁员,所以很多人问,程序员怎么找工作?找工作越来越难怎么办...

    2024-01-30 22:05:25
  • 实战|手把手教你用Python爬虫(附详细源码)

    实战|手把手教你用Python爬虫(附详细源码)

    实践来源于理论,做爬虫前肯定要先了解相关的规则和原理,要知道互联网可不是法外之地,你一顿爬虫骚操作搞不好哪天就…首先,咱先看下爬虫的定义:网络爬虫(又称为网页蜘蛛,网络机器人,在FOAF社区中间,更经常的称为网页追逐者),是一种按照一定的规则,自动地抓取万维网信息的程序或者脚本。一句话概括就是网上信息搬运工。

    2024-01-30 22:04:49
  • 使用stream把对象中的属性过滤出来后转成list后求和

    使用stream把对象中的属性过滤出来后转成list后求和 写一个简单的例子 相信聪明如你一看就懂 User user = new User("a",1,"男"...

    2024-01-30 22:04:43
  • Nexus上传jar包到私有Maven仓库的方法: 页面Upload 和命令

    Nexus上传jar包到私有Maven仓库的方法: 页面Upload 和命令

    选择Upload,选择要上传的目标仓库,选择 File 填写 Group ID 等,最重要的是要点选。命令两种上传方式的应用场景不同,手动上传适用于工具类的。文件,这种可以选择手动上传。复杂的、有较多依赖的。文件一起上传,此时需要使用。包,比如项目需要引入的。不勾选,上传成功后没有。

    2024-01-30 22:04:35
  • 进程互斥与同步计算机操作系统_操作系统心得体会

    进程互斥与同步计算机操作系统_操作系统心得体会

    一、操作系统1.基本概念操作系统简称OS,是配置在计算机硬件上的第一层软件,它能够有效的组织和管理计算机系统中的硬件和软件资源,合理的组织计算机工作流程,控制程序的执行,并向用户提供各种服务功能。OS...

    2024-01-30 22:04:07
  • MySQL事务基础知识

    MySQL事务基础知识

    目录1.数据库事务概述1.1 存储引擎支持情况1.2 事务基本概念1.3 事务的ACID特性1.4 事务的状态2.如何使用事务3.事务的隔离级别4.事务的常见分类1.数据库事务概述1.1 存储引擎支持...

    2024-01-30 22:03:59
  • 深入浅出C语言——C语言简介

    深入浅出C语言——C语言简介

    C语言的内容简介

    2024-01-30 22:03:52
  • Java中输入一个整数n,实现n的阶乘

    Java中输入一个整数n,实现n的阶乘

    n的阶乘:1!+2!+3!+…+n! public static void main(String[] args) { //2.输入一个整数n,实现n的阶乘。n*(n-1)*......*1 Scan...

    2024-01-30 22:03:46
  • 台式计算机有哪些特性,计算机的主要特点有哪些

    大家好,我是时间财富网智能客服时间君,上述问题将由我为大家进行解答。计算机具有以下几个主要特点:1、运算速度快目前最快的巨型机运行速度已达每秒100多亿次,这是传统计算工具所无法比拟的。随着科学技术的...

    2024-01-30 22:03:16